nunojob:~ dscape/08$ echo The Black Sheep

A paciencia tem os seus limites e vou dormir. Se entretanto alguém descobrir a solução para isto peço-lhe o favor de me deixar nos comentários.

Comments on: "This version of RMagick was created to run with ImageMagick 6.3.3 but ImageMagick 6.3.8 is in use" (1)

  1. Solved!

    O que fazer para resolver isto. Primeiro se estão obrigados a usar proxy. Foda-se. Vão ter dores de cabeça. MacPorts? ESQUEÇAM.

    Saquem o ImageMagick precompilado pra macos e adicionem ao path mesmo a morcões (no .profile).

    Agora instalem o rmagick. Façam require ‘RMagick’ no config/environment.rb e ./script/server

    Deu erro? Se não deu melhor. A mim deu..

    Tirem o rmagick do path. Saquem de um qualquer mirror do imagemagick a versao que eles pedem (sim façam downgrade)

    ./configure
    make
    sudo make install

    30 minutos depois
    imagemagick a rular

    gem uninstall rmagick
    gem install rmagick (-p http://proxy.uminho.pt:3128 para proxies)

    façam update ao gems

    gem update –SYSTEM

    ./script/server

    Problemas resolvido

    If anyone wants this solution in english just leave me a comment and ill translate it for you.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: